Mk1 radio wiring

Post here if you require help or have information that may assist others with their MX-5.

Mk1 radio wiring

Postby Ginger Nuts » Sun Oct 18, 2015 4:39 pm

Hi all,

I've got an original stereo in my Mk1 Import, and while the radio works fine apart from scanning slightly offset being an import the cd player won't play - it's got power and spins up but I reckon the laser is just old and gubbed. I've tried cleaning it loads of times but no joy.

Sooooo, I've got an old Sony radio/cd player sitting doing nothing and have had the brilliant idea of splitting the units and replacing the original cd player with my old Sony one, the original radio would then be just for filling a hole.

Still with me???

Anyway, having removed the original unit I find that the wiring to the plugs is completely different to my more up to date one. I've been down a scrappies and cut out a section of wiring from someone's Mk1 that must have done the same but still unsure as to what is what.

Is there a way to tell what's speaker wire / power etc??

If I knew how to upload images I have a couple of photos to demonstrate what I mean.

I'm pretty sure it can't be that hard I just need to swap wires onto new connectors and voila, probably why I'm a bit frustrated! :roll:
Ginger Nuts
User avatar
 
Posts: 60
Joined: Thu Oct 09, 2014 4:30 pm
Location: Dunfermline

Re: Mk1 radio wiring

Postby drumtochty » Sun Oct 18, 2015 5:14 pm

Open a photobucket.com account.

Upload your picture there as the photobucket site will instruct you

As you display each picture on the photobucket site there are boxes on the right hand side of the screen, click on the image box and that copies the details to your computers clipboard.

Go back to the MX5scotland website and do a paste in you message and that puts code in that will display the picture to users of the MX5scotland.

So get that sorted and we can see the pictures and advise you how to get further with the wiring.
99 Mk2 1.8 IS Silver
08 Mk3 2.0 RC Sport Copper Red
drumtochty
User avatar
OC Member
Eddie Cairns
MX-5 OC Club Member
 
Posts: 2584
Joined: Thu Jun 18, 2009 1:42 pm
Location: Drumtochty Glen, Auchenblae

Re: Mk1 radio wiring

Postby Ginger Nuts » Sun Oct 18, 2015 6:04 pm

I'll get on the photo bucket thing shortly, meantime I've found that the power supply for the old unit seams to have been a single red wire attached by a screw and plate to the body of the unit.
That can't be right?
So I'm thinking I need to integrate this into a connector block for the new player.
I've found and ordered a harness adaptor but this live wire is confusing me.
Knew I should have left well alone!

Image

Got the adaptor to connect the two white plugs shown but the red wire disappearing out of shot would appear to be the power supply??
Ginger Nuts
User avatar
 
Posts: 60
Joined: Thu Oct 09, 2014 4:30 pm
Location: Dunfermline

Re: Mk1 radio wiring

Postby 71NotOut » Sun Oct 18, 2015 6:46 pm

If the wire is attached to the chassis of the stereo are you sure they haven't just used a red wire for an earth?

My Eunos was a rat's nest behind the stereo but thankfully the purchase of an iso adaptor cable tidied everything up when I bought my new Sony mp3 head unit.
Previously in a 2003 Montana, now in a 1991 V-Special...
71NotOut
User avatar
OC Member
Steven Hedley
MX-5 OC Club Member
 
Posts: 408
Joined: Tue Apr 20, 2010 1:29 pm
Location: Bilston

Re: Mk1 radio wiring

Postby Ginger Nuts » Sun Oct 18, 2015 7:18 pm

Went for a shower and a think, yep I've got a red earth wire.

So I think I'm good to go when the adaptor arrives.

Just as well because there's all sorts of old wires in there, talk about a birds nest!

I'll let you know if all goes well - might even look for a new Bluetooth / DAB thingy if this works.

:D
Ginger Nuts
User avatar
 
Posts: 60
Joined: Thu Oct 09, 2014 4:30 pm
Location: Dunfermline


Return to Technical

Who is online

Users browsing this forum: No registered users and 3 guests