MK 3.5 Heater Issue

Post here if you require help or have information that may assist others with their MX-5.

MK 3.5 Heater Issue

Postby special k » Fri Apr 17, 2015 3:33 pm

Afternoon All

My boss has a MK3.5 (2009) 2.0 sportech and he mentioned to me today that he seems to have an issue with the heater. He has had it for a few months with no issues however he has noticed recently that heater when turned to a mid temp range blows lukewarm air. When turned to full heat it still blows lukewarm air which is strange as it was fine before. I wondered if there was anyone out there that has encountered this problem or could assist & perhaps advise of a possible solution

Regards
special k
User avatar
OC Member
Steven Kilpatrick
MX-5 OC Club Member
 
Posts: 33
Joined: Sat Apr 14, 2012 6:58 pm
Location: Fife

Re: MK 3.5 Heater Issue

Postby drumtochty » Fri Apr 17, 2015 3:40 pm

First job is to check there is plenty fluid in the radiator.

The temperature guage in these cars is just a toy so they do not give accurate readings.
99 Mk2 1.8 IS Silver
08 Mk3 2.0 RC Sport Copper Red
drumtochty
User avatar
OC Member
Eddie Cairns
MX-5 OC Club Member
 
Posts: 2584
Joined: Thu Jun 18, 2009 1:42 pm
Location: Drumtochty Glen, Auchenblae

Re: MK 3.5 Heater Issue

Postby IanH » Fri Apr 17, 2015 6:18 pm

IanH
User avatar
OC Member
Ian Hindmarsh
Site Admin
 
Posts: 2559
Joined: Fri Oct 08, 2004 10:53 am
Location: not the end of the world, but you can see it from here or near Inverurie.

Re: MK 3.5 Heater Issue

Postby special k » Fri Apr 17, 2015 9:14 pm

Eddie many thanks. Coolant level checked and is fine

Ian many thanks for the thread regards similar issues stateside. Will pass the info on

Regards
special k
User avatar
OC Member
Steven Kilpatrick
MX-5 OC Club Member
 
Posts: 33
Joined: Sat Apr 14, 2012 6:58 pm
Location: Fife


Return to Technical

Who is online

Users browsing this forum: No registered users and 2 guests

cron