Clutch Issue

Post here if you require help or have information that may assist others with their MX-5.

Clutch Issue

Postby Dan_Mosca » Tue Mar 03, 2015 5:31 pm

Last month I had to replace the clutch slave cylinder as the biting point of the clutch got closer and closer to the floor until I could no longer select gear as the clutch had gone soft. After replacing with a new clutch slave cylinder and i got about three weeks out of driving the car. For the last week each time i go out to drive the car after it sits over night the clutch has no pressure at all until it is pumped a few times. On the drive home last night the pressure went completed and now it is very difficult to get gear at all.

I have had a look at the slave and there are no leaks, looked at the master and its the same, fluid levels are normal.

Anyone any ideas?
1999 MK2 1.8i S in Silver
Dan_Mosca
 
Posts: 12
Joined: Tue Mar 03, 2015 1:36 pm

Re: Clutch Issue

Postby drumtochty » Tue Mar 03, 2015 10:18 pm

Air in the system!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1

eddie
99 Mk2 1.8 IS Silver
08 Mk3 2.0 RC Sport Copper Red
drumtochty
User avatar
OC Member
Eddie Cairns
MX-5 OC Club Member
 
Posts: 2601
Joined: Thu Jun 18, 2009 1:42 pm
Location: Drumtochty Glen, Auchenblae

Re: Clutch Issue

Postby BoabG » Wed Mar 04, 2015 8:47 am

Sounds like you'll have to re-bleed the system.
2004- MX5 Euphonic in Titanium.
BoabG
OC Member
Bob Gray
MX-5 OC Club Member
 
Posts: 135
Joined: Fri Nov 07, 2014 6:11 am

Re: Clutch Issue

Postby Dan_Mosca » Wed Mar 04, 2015 2:57 pm

Turns out it was a faulty Slave Cylinder that went into the car....she's in the mechanics right now getting it changed :)
1999 MK2 1.8i S in Silver
Dan_Mosca
 
Posts: 12
Joined: Tue Mar 03, 2015 1:36 pm


Return to Technical

Who is online

Users browsing this forum: No registered users and 2 guests

cron