Burning oil smell after driving

Post here if you require help or have information that may assist others with their MX-5.

Burning oil smell after driving

Postby secat187 » Tue Feb 22, 2005 2:15 pm

Has anyone else noticed a smell of burning oil possibly coming from the back axle?
I noticed it on my old 1.6 mx5 and now on my 1.8. Is it another 'feature' of the car. I dont seem to be dripping oil from anywhere.

any Ideas?
secat187
User avatar
 
Posts: 522
Joined: Mon Jan 10, 2005 7:12 pm
Location: Glasgow

Postby mgrays » Tue Feb 22, 2005 6:28 pm

More likely the CAS O ring .. this is the timing pickup at the back of the engine (changed sides from 1.6 to 1.8 - the side where the ignition leads do not go is where the CAS is). This O ring dies after 8 years or so .. and then the oil can drip down on the exhaust manifold on a 1.8.. but normally it just covers the front bellhousing of the gearbox.

Otherwise.. not sure it is just you smelling diesel cars with the roof down .. first time you follow one you really notice it.
Malcolm GS
94 JLtd2 FM2
mgrays
 
Posts: 577
Joined: Mon Jul 19, 2004 7:03 pm
Location: Aberdeen, Scotland

Postby secat187 » Tue Feb 22, 2005 6:38 pm

Cheers, I'll have a look when I get round to servicing it.
secat187
User avatar
 
Posts: 522
Joined: Mon Jan 10, 2005 7:12 pm
Location: Glasgow

Postby Si » Tue Feb 22, 2005 7:24 pm

mgrays wrote:More likely the CAS O ring .. this is the timing pickup at the back of the engine (changed sides from 1.6 to 1.8 - the side where the ignition leads do not go is where the CAS is). This O ring dies after 8 years or so .. and then the oil can drip down on the exhaust manifold on a 1.8.. but normally it just covers the front bellhousing of the gearbox.


That's EXACTLY the symptoms of mine. Is it an easy job to replace, or should I just take it to the garage?

Brilliant info as usual Malcolm :)

Si
.:- Bye bye Maxine (1997 1.8iS Mk1 BRP MP62)
.:- Hello Ruby (2000 1.6i Isola)
Si
User avatar
 
Posts: 1608
Joined: Wed Jun 23, 2004 1:23 pm
Location: What's it called?

Postby Si » Tue Feb 22, 2005 7:25 pm

P.S. sorry for the thread hi-jack :oops:
Si
User avatar
 
Posts: 1608
Joined: Wed Jun 23, 2004 1:23 pm
Location: What's it called?

Postby secat187 » Wed Feb 23, 2005 12:42 am

It's ok.
secat187
User avatar
 
Posts: 522
Joined: Mon Jan 10, 2005 7:12 pm
Location: Glasgow

Postby Richardn » Wed Feb 23, 2005 9:01 am

Full instructions in the usual place :D


http://www.miata.net/garage/cas_oring.html
Mk3 2.0 sport & Mk1 California 217/300
Richardn
User avatar
MX-5 OC Club Member
 
Posts: 3190
Joined: Fri Jun 25, 2004 10:43 pm
Location: Sunny, midge free Cheshire


Return to Technical

Who is online

Users browsing this forum: Google [Bot] and 2 guests